CVE-2025-24013

Medium

Description

CodeIgniter is a PHP full-stack web framework. Prior to 4.5.8, CodeIgniter lacked proper header validation for its name and value. The potential attacker can construct deliberately malformed headers with Header class. This could disrupt application functionality, potentially causing errors or generating invalid HTTP requests. In some cases, these malformed requests might lead to a DoS scenario if a remote service’s web application firewall interprets them as malicious and blocks further communication with the application. This vulnerability is fixed in 4.5.8.

SeverityMedium
CVSS5.3
Exploit probability—
ProductCodeigniter
PublishedJan 20, 2025
First seenJan 20, 2025
Weakness typeCWE-436CWE-436

How to fix

Update
  • codeigniter codeigniter4.5.8 or later
  • codeigniter4/framework4.5.8 or later

Affected products

ProductAffected versionsFixed in
codeigniter codeigniterv < 4.5.84.5.8
codeigniter4/frameworkPackagistv < 4.5.84.5.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.