CVE-2025-24791
Description
snowflake-connector-nodejs is a NodeJS driver for Snowflake. Snowflake discovered and remediated a vulnerability in the Snowflake NodeJS Driver. File permissions checks of the temporary credential cache could be bypassed by an attacker with write access to the local cache directory. This vulnerability affects versions 1.12.0 through 2.0.1 on Linux. Snowflake fixed the issue in version 2.0.2.
How to fix
- snowflake snowflake_connector2.0.2 or later
- snowflake-sdk2.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| snowflake snowflake_connector | 1.12.0 ≤ v < 2.0.2 | 2.0.2 |
| snowflake-sdknpm | 1.12.0 ≤ v < 2.0.2 | 2.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.