CVE-2025-24793
Description
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. A function from the snowflake.connector.pandas_tools module is vulnerable to SQL injection. This vulnerability affects versions 2.2.5 through 3.13.0. Snowflake fixed the issue in version 3.13.1.
How to fix
- snowflake snowflake_connector3.13.1 or later
- snowflake-connector-python3.13.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| snowflake snowflake_connector | 2.2.5 ≤ v < 3.13.1 | 3.13.1 |
| snowflake-connector-pythonPyPI | 2.2.5 ≤ v < 3.13.1 | 3.13.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.