CVE-2025-24794
Description
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the serialization format, potentially leading to local privilege escalation. This vulnerability affects versions 2.7.12 through 3.13.0. Snowflake fixed the issue in version 3.13.1.
How to fix
- snowflake snowflake_connector3.13.1 or later
- snowflake-connector-python3.13.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| snowflake snowflake_connector | 2.7.12 ≤ v < 3.13.1 | 3.13.1 |
| snowflake-connector-pythonPyPI | 2.7.12 ≤ v < 3.13.1 | 3.13.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.