CVE-2025-24813
Description
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
How to fix
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
CISA due date: Apr 22, 2025- apache tomcat9.0.99, 10.1.35, 11.0.3 or later
- org.apache.tomcat:tomcat-catalina11.0.3, 10.1.35, 9.0.99 or later
- org.apache.tomcat.embed:tomcat-embed-core11.0.3, 10.1.35, 9.0.99 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | v < 9.0.99, 10.1.1 ≤ v < 10.1.35, 11.0.1 ≤ v < 11.0.3, 10.1.0, 11.0.0 | 9.0.99, 10.1.35, 11.0.3 |
| debian debian_linux | 11.0 | — |
| netapp bootstrap_os | No range specified | — |
| org.apache.tomcat:tomcat-catalinaMaven | 11.0.0-M1 ≤ v < 11.0.3, 10.1.0-M1 ≤ v < 10.1.35, 9.0.0.M1 ≤ v < 9.0.99, 8.5.0 ≤ v ≤ 8.5.100 | 11.0.3, 10.1.35, 9.0.99 |
| org.apache.tomcat.embed:tomcat-embed-coreMaven | 11.0.0-M1 ≤ v < 11.0.3, 10.1.0-M1 ≤ v < 10.1.35, 9.0.0.M1 ≤ v < 9.0.99, 8.5.0 ≤ v ≤ 8.5.100 | 11.0.3, 10.1.35, 9.0.99 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.