CVE-2025-24814

Medium

Description

Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem.  These replacement config files are treated as "trusted" and can use "<lib>" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7.  Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService").  Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of "<lib>" tags by default.

SeverityMedium
CVSS5.5
Exploit probability—
ProductApache Solr
PublishedJan 27, 2025
First seenJan 27, 2025
Weakness typeCWE-250CWE-250

How to fix

Update
  • apache solr9.8.0 or later
  • org.apache.solr:solr-core9.8.0 or later

Affected products

ProductAffected versionsFixed in
apache solrv < 9.8.09.8.0
org.apache.solr:solr-coreMavenv < 9.8.09.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.