CVE-2025-24859

High

Description

A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised. This issue affects Apache Roller versions up to and including 6.1.4. The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Roller
PublishedApr 14, 2025
First seenApr 14, 2025
Weakness typeCWE-613CWE-613

How to fix

Affected products

ProductAffected versionsFixed in
apache roller1.0 ≤ v < 6.1.56.1.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.