CVE-2025-24964
Description
Vitest is a testing framework powered by Vite. Affected versions are subject to arbitrary remote Code Execution when accessing a malicious website while Vitest API server is listening by Cross-site WebSocket hijacking (CSWSH) attacks. When `api` option is enabled (Vitest UI enables it), Vitest starts a WebSocket server. This WebSocket server did not check Origin header and did not have any authorization mechanism and was vulnerable to CSWSH attacks. This WebSocket server has `saveTestFile` API that can edit a test file and `rerun` API that can rerun the tests. An attacker can execute arbitrary code by injecting a code in a test file by the `saveTestFile` API and then running that file by calling the `rerun` API. This vulnerability can result in remote code execution for users that are using Vitest serve API. This issue has been patched in versions 1.6.1, 2.1.9 and 3.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
How to fix
- vitest.dev vitest1.6.1, 2.1.9, 3.0.5 or later
- vitest1.6.1, 2.1.9, 3.0.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vitest.dev vitest | v ≤ 0.0.125, 1.0.0 ≤ v < 1.6.1, 2.0.0 ≤ v < 2.1.9, 3.0.0 ≤ v < 3.0.5 | 1.6.1, 2.1.9, 3.0.5 |
| vitestnpm | 1.0.0 ≤ v < 1.6.1, 2.0.0 ≤ v < 2.1.9, 3.0.0 ≤ v < 3.0.5, v ≤ 0.0.125 | 1.6.1, 2.1.9, 3.0.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.