CVE-2025-25196

Critical

Description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA < v1.8.4 (Helm chart < openfga-0.2.22, docker < v.1.8.4) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users on OpenFGA v1.8.4 or previous, specifically under the following conditions are affected by this authorization bypass vulnerability: 1. Calling Check API or ListObjects with a model that has a relation directly assignable to both public access AND userset with the same type. 2. A type bound public access tuple is assigned to an object. 3. userset tuple is not assigned to the same object. and 4. Check request's user field is a userset that has the same type as the type bound public access tuple's user type. Users are advised to upgrade to v1.8.5 which is backwards compatible. There are no known workarounds for this vulnerability.

SeverityCritical
CVSS9.8
Exploit probability—
ProductOpenfga Helm Charts
PublishedFeb 19, 2025
First seenFeb 19, 2025
Weakness typeCWE-285CWE-285

How to fix

Update
  • openfga helm_charts0.2.22 or later
  • openfga openfga1.8.5 or later
  • github.com/openfga/openfga1.8.5 or later

Affected products

ProductAffected versionsFixed in
openfga helm_chartsv < 0.2.220.2.22
openfga openfgav < 1.8.51.8.5
github.com/openfga/openfgaGov < 1.8.51.8.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.