CVE-2025-25247
Medium
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole. This issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8. Users are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.
SeverityMedium
CVSS6.1
Exploit probability—
Product
Apache Felix Webconsole
PublishedFeb 10, 2025
First seenFeb 10, 2025
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- apache felix_webconsole4.9.10, 5.0.10 or later
- org.apache.felix:org.apache.felix.webconsole4.9.10, 5.0.10 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache felix_webconsole | 4.0.0 ≤ v < 4.9.10, 5.0.0 ≤ v < 5.0.10 | 4.9.10, 5.0.10 |
| org.apache.felix:org.apache.felix.webconsoleMaven | 4.0.0 ≤ v < 4.9.10, 5.0.0 ≤ v < 5.0.10 | 4.9.10, 5.0.10 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.