CVE-2025-25299
Description
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. During a recent internal audit, a Cross-Site Scripting (XSS) vulnerability was discovered in the CKEditor 5 real-time collaboration package. This vulnerability affects user markers, which represent users' positions within the document. It can lead to unauthorized JavaScript code execution, which might happen with a very specific editor and token endpoint configuration. This vulnerability affects only installations with Real-time collaborative editing enabled. The problem has been recognized and patched. The fix is available in version 44.2.1 (and above). Users are advised to upgrade. There are no known workarounds for this vulnerability.
How to fix
- @ckeditor/ckeditor5-real-time-collaboration44.2.1 or later
- ckeditor5-premium-features44.2.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @ckeditor/ckeditor5-real-time-collaborationnpm | 41.3.0 ≤ v < 44.2.1 | 44.2.1 |
| ckeditor5-premium-featuresnpm | 42.0.0 ≤ v < 44.2.1 | 44.2.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.