CVE-2025-26413
High
Description
Improper Input Validation vulnerability in Apache Kvrocks. The SETRANGE command didn't check if the `offset` input is a positive integer and use it as an index of a string. So it will cause the server to crash due to its index is out of range. This issue affects Apache Kvrocks: through 2.11.1. Users are recommended to upgrade to version 2.12.0, which fixes the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Kvrocks
PublishedApr 22, 2025
First seenApr 22, 2025
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache kvrocks2.12.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache kvrocks | v < 2.12.0 | 2.12.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.