CVE-2025-26467

High

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected. Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Cassandra
PublishedAug 25, 2025
First seenAug 25, 2025
Weakness typeCWE-267CWE-267

How to fix

Update
  • apache cassandra3.0.31, 3.11.18, 4.0.17, 4.1.8, 5.0.3 or later
  • org.apache.cassandra:cassandra-all4.0.17 or later

Affected products

ProductAffected versionsFixed in
apache cassandra3.0.0 ≤ v < 3.0.31, 3.11.0 ≤ v < 3.11.18, 4.0.0 ≤ v < 4.0.17, 4.1.0 ≤ v < 4.1.8, 5.0.0 ≤ v < 5.0.33.0.31, 3.11.18, 4.0.17, 4.1.8, 5.0.3
org.apache.cassandra:cassandra-allMaven4.0.16 ≤ v < 4.0.174.0.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.