CVE-2025-26795

High

Description

Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerability in Apache IoTDB JDBC driver. This issue affects iotdb-jdbc: from 0.10.0 through 1.3.3, from 2.0.1-beta before 2.0.2. Users are recommended to upgrade to version 2.0.2 and 1.3.4, which fix the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Iotdb
PublishedMay 14, 2025
First seenMay 14, 2025

How to fix

Update
  • apache iotdb1.3.4, 2.0.2 or later
  • org.apache.iotdb:iotdb-jdbc1.3.4, 2.0.2 or later

Affected products

ProductAffected versionsFixed in
apache iotdb0.10.0 ≤ v < 1.3.4, 2.0.1 ≤ v < 2.0.21.3.4, 2.0.2
org.apache.iotdb:iotdb-jdbcMaven0.10.0 ≤ v < 1.3.4, 2.0.1-beta ≤ v < 2.0.21.3.4, 2.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.