CVE-2025-26864
High
Description
Exposure of Sensitive Information to an Unauthorized Actor, Insertion of Sensitive Information into Log File vulnerability in the OpenIdAuthorizer of Apache IoTDB. This issue affects Apache IoTDB: from 0.10.0 through 1.3.3, from 2.0.1-beta before 2.0.2. Users are recommended to upgrade to version 1.3.4 and 2.0.2, which fix the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Iotdb
PublishedMay 14, 2025
First seenMay 14, 2025
Weakness typeCWE-200Sensitive information exposureCWE-532CWE-532
How to fix
Update
- apache iotdb1.3.4 or later
- org.apache.iotdb:node-commons1.3.4, 2.0.2 or later
- apache-iotdb1.3.4, 2.0.2 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache iotdb | 0.10.0 ≤ v < 1.3.4, 2.0.1 | 1.3.4 |
| org.apache.iotdb:node-commonsMaven | 0.10.0 ≤ v < 1.3.4, 2.0.1-beta ≤ v < 2.0.2 | 1.3.4, 2.0.2 |
| apache-iotdbPyPI | 0.10.0 ≤ v < 1.3.4, 2.0.1b0 ≤ v < 2.0.2 | 1.3.4, 2.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.