CVE-2025-27446

High

Description

Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-runner). Local listening file permissions in APISIX plugin runner allow a local attacker to elevate privileges. This issue affects Apache APISIX(java-plugin-runner): from 0.2.0 through 0.5.0. Users are recommended to upgrade to version 0.6.0 or higher, which fixes the issue.

SeverityHigh
CVSS7.8
Exploit probability—
ProductApache Apisix
PublishedJul 6, 2025
First seenJul 6, 2025
Weakness typeCWE-732CWE-732

How to fix

Affected products

ProductAffected versionsFixed in
apache apisix0.2 ≤ v ≤ 0.5—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.