CVE-2025-27505
Description
GeoServer is an open source server that allows users to share and edit geospatial data. It is possible to bypass the default REST API security and access the index page. The REST API security handles rest and its subpaths but not rest with an extension (e.g., rest.html). The REST API index can disclose whether certain extensions are installed. This vulnerability is fixed in 2.26.3 and 2.25.6. As a workaround, in ${GEOSERVER_DATA_DIR}/security/config.xml, change the paths for the rest filter to /rest.*,/rest/** and change the paths for the gwc filter to /gwc/rest.*,/gwc/rest/** and restart GeoServer.
How to fix
- osgeo geoserver2.25.6, 2.26.3 or later
- org.geoserver.web:gs-web-app2.26.3, 2.25.6 or later
- org.geoserver:gs-rest2.26.3, 2.25.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| osgeo geoserver | v < 2.25.6, 2.26.0 ≤ v < 2.26.3 | 2.25.6, 2.26.3 |
| org.geoserver.web:gs-web-appMaven | 2.26.0 ≤ v < 2.26.3, v < 2.25.6 | 2.26.3, 2.25.6 |
| org.geoserver:gs-restMaven | 2.26.0 ≤ v < 2.26.3, v < 2.25.6 | 2.26.3, 2.25.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.