CVE-2025-27515
Critical
Description
Laravel is a web application framework. When using wildcard validation to validate a given file or image field (`files.*`), a user-crafted malicious request could potentially bypass the validation rules. This vulnerability is fixed in 11.44.1 and 12.1.1.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Laravel Framework
PublishedMar 5, 2025
First seenMar 5, 2025
Weakness typeCWE-155CWE-155
How to fix
Update
- laravel framework11.44.1, 12.1.1 or later
- laravel/framework12.1.1, 11.44.1, 10.48.29 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| laravel framework | v < 11.44.1, 12.0.0 ≤ v < 12.1.1 | 11.44.1, 12.1.1 |
| laravel/frameworkPackagist | 12.0.0 ≤ v < 12.1.1, 11.0.0 ≤ v < 11.44.1, v < 10.48.29 | 12.1.1, 11.44.1, 10.48.29 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.