CVE-2025-27528
Description
Deserialization of Untrusted Data vulnerability in Apache InLong. This issue affects Apache InLong: from 1.13.0 through 2.1.0. This vulnerability allows attackers to bypass the security mechanisms of InLong JDBC and leads to arbitrary file reading. Users are advised to upgrade to Apache InLong's 2.2.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/11747
How to fix
- apache inlong2.2.0 or later
- org.apache.inlong:manager-pojo2.2.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache inlong | 1.13.0 ≤ v < 2.2.0 | 2.2.0 |
| org.apache.inlong:manager-pojoMaven | 1.13.0 ≤ v < 2.2.0 | 2.2.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.