CVE-2025-27531

Critical

Description

Deserialization of Untrusted Data vulnerability in Apache InLong.  This issue affects Apache InLong: from 1.13.0 before 2.1.0, this issue would allow an authenticated attacker to read arbitrary files by double writing the param. Users are recommended to upgrade to version 2.1.0, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Inlong
PublishedJun 6, 2025
First seenJun 6, 2025

How to fix

Update
  • apache inlong2.1.0 or later
  • org.apache.inlong:inlong-manager2.1.0 or later

Affected products

ProductAffected versionsFixed in
apache inlong1.13.0 ≤ v < 2.1.02.1.0
org.apache.inlong:inlong-managerMaven1.13.0 ≤ v < 2.1.02.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.