CVE-2025-27598

High

Description

ImageSharp is a 2D graphics API. An Out-of-bounds Write vulnerability has been found in the ImageSharp gif decoder, allowing attackers to cause a crash using a specially crafted gif. This can potentially lead to denial of service. The problem has been patched. All users are advised to upgrade to v3.1.7 or v2.1.10.

SeverityHigh
CVSS7.5
Exploit probability—
ProductSixlabors Imagesharp
PublishedMar 6, 2025
First seenMar 6, 2025

How to fix

Update
  • sixlabors imagesharp2.1.10, 3.1.7 or later
  • SixLabors.ImageSharp3.1.7, 2.1.10 or later

Affected products

ProductAffected versionsFixed in
sixlabors imagesharpv < 2.1.10, 3.0.0 ≤ v < 3.1.72.1.10, 3.1.7
SixLabors.ImageSharpNuGet3.0.0 ≤ v < 3.1.7, v < 2.1.103.1.7, 2.1.10

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.