CVE-2025-27696

High

Description

Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Superset
PublishedMay 13, 2025
First seenMay 13, 2025

How to fix

Update
  • apache superset4.1.2 or later
  • apache-superset4.1.2 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 4.1.24.1.2
apache-supersetPyPIv < 4.1.24.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.