CVE-2025-27789
Description
Babel is a compiler for writing next generation JavaScript. When using versions of Babel prior to 7.26.10 and 8.0.0-alpha.17 to compile regular expression named capturing groups, Babel will generate a polyfill for the `.replace` method that has quadratic complexity on some specific replacement pattern strings (i.e. the second argument passed to `.replace`). Generated code is vulnerable if all the following conditions are true: Using Babel to compile regular expression named capturing groups, using the `.replace` method on a regular expression that contains named capturing groups, and the code using untrusted strings as the second argument of `.replace`. This problem has been fixed in `@babel/helpers` and `@babel/runtime` 7.26.10 and 8.0.0-alpha.17. It's likely that individual users do not directly depend on `@babel/helpers`, and instead depend on `@babel/core` (which itself depends on `@babel/helpers`). Upgrading to `@babel/core` 7.26.10 is not required, but it guarantees use of a new enough `@babel/helpers` version. Note that just updating Babel dependencies is not enough; one will also need to re-compile the code. No known workarounds are available.
How to fix
- @babel/helpers7.26.10, 8.0.0-alpha.17 or later
- @babel/runtime7.26.10, 8.0.0-alpha.17 or later
- @babel/runtime-corejs27.26.10, 8.0.0-alpha.17 or later
- @babel/runtime-corejs37.26.10, 8.0.0-alpha.17 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @babel/helpersnpm | v < 7.26.10, 8.0.0-alpha.0 ≤ v < 8.0.0-alpha.17 | 7.26.10, 8.0.0-alpha.17 |
| @babel/runtimenpm | v < 7.26.10, 8.0.0-alpha.0 ≤ v < 8.0.0-alpha.17 | 7.26.10, 8.0.0-alpha.17 |
| @babel/runtime-corejs2npm | v < 7.26.10, 8.0.0-alpha.0 ≤ v < 8.0.0-alpha.17 | 7.26.10, 8.0.0-alpha.17 |
| @babel/runtime-corejs3npm | v < 7.26.10, 8.0.0-alpha.0 ≤ v < 8.0.0-alpha.17 | 7.26.10, 8.0.0-alpha.17 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.