CVE-2025-27821

High

Description

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.

SeverityHigh
CVSS7.3
Exploit probability—
ProductApache Hadoop
PublishedJan 26, 2026
First seenJan 26, 2026

How to fix

Update
  • apache hadoop3.4.2 or later
  • org.apache.hadoop:hadoop-hdfs-native-client3.4.2 or later

Affected products

ProductAffected versionsFixed in
apache hadoop3.2.0 ≤ v < 3.4.23.4.2
org.apache.hadoop:hadoop-hdfs-native-clientMaven3.2.0 ≤ v < 3.4.23.4.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.