CVE-2025-27867
Medium
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix HTTP Webconsole Plugin. This issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0. Users are recommended to upgrade to version 1.2.2, which fixes the issue.
SeverityMedium
CVSS5.6
Exploit probability47. percentile0.6%
Product
Apache Felix Http Webconsole Plugin
PublishedMar 12, 2025
First seenMar 12, 2025
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- apache felix_http_webconsole_plugin1.2.2 or later
- org.apache.felix:org.apache.felix.http.webconsoleplugin1.2.2 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache felix_http_webconsole_plugin | 1.0.0 ≤ v < 1.2.2 | 1.2.2 |
| org.apache.felix:org.apache.felix.http.webconsolepluginMaven | v < 1.2.2 | 1.2.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.