CVE-2025-27888
Description
Severity: medium (5.8) / important Server-Side Request Forgery (SSRF), Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'), URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache Druid. This issue affects all previous Druid versions. When using the Druid management proxy, a request that has a specially crafted URL could be used to redirect the request to an arbitrary server instead. This has the potential for XSS or XSRF. The user is required to be authenticated for this exploit. The management proxy is enabled in Druid's out-of-box configuration. It may be disabled to mitigate this vulnerability. If the management proxy is disabled, some web console features will not work properly, but core functionality is unaffected. Users are recommended to upgrade to Druid 31.0.2 or Druid 32.0.1, which fixes the issue.
How to fix
- apache druid31.0.2 or later
- org.apache.druid:druid31.0.2, 32.0.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache druid | v < 31.0.2 | 31.0.2 |
| org.apache.druid:druidMaven | v < 31.0.2, 32.0.0 ≤ v < 32.0.1 | 31.0.2, 32.0.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.