CVE-2025-2817
Description
Thunderbird's update mechanism allowed a medium-integrity user process to interfere with the SYSTEM-level updater by manipulating the file-locking behavior. By injecting code into the user-privileged process, an attacker could bypass intended access controls, allowing SYSTEM-level file operations on paths controlled by a non-privileged user and enabling privilege escalation. This vulnerability was fixed in Firefox 138, Firefox ESR 128.10, Firefox ESR 115.23, Thunderbird 138, and Thunderbird 128.10.
How to fix
- mozilla firefox115.23.0, 138.0, 128.10.0 or later
- mozilla thunderbird128.10.0, 138.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| mozilla firefox | v < 115.23.0, v < 138.0, 116.0 ≤ v < 128.10.0 | 115.23.0, 138.0, 128.10.0 |
| mozilla thunderbird | v < 128.10.0, 129.0 ≤ v < 138.0 | 128.10.0, 138.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.