CVE-2025-29768

Medium

Description

Vim, a text editor, is vulnerable to potential data loss with zip.vim and special crafted zip files in versions prior to 9.1.1198. The impact is medium because a user must be made to view such an archive with Vim and then press 'x' on such a strange filename. The issue has been fixed as of Vim patch v9.1.1198.

SeverityMedium
CVSS4.4
Exploit probability—
ProductVim
PublishedMar 13, 2025
First seenMar 13, 2025
Weakness typeCWE-88CWE-88

How to fix

Update
  • vim vim9.1.1198 or later

Affected products

ProductAffected versionsFixed in
vim vimv < 9.1.11989.1.1198
netapp bootstrap_osNo range specified—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.