CVE-2025-29783

Critical

Description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.

SeverityCritical
CVSS9.0
Exploit probability—
ProductVllm
PublishedMar 19, 2025
First seenMar 19, 2025

How to fix

Update
  • vllm vllm0.8.0 or later
  • vllm0.8.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.6.5 ≤ v < 0.8.00.8.0
vllmPyPI0.6.5 ≤ v < 0.8.00.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.