CVE-2025-29891

Medium

Description

Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, or the camel-exec component. If you have Camel applications that are directly connected to the internet via HTTP, then an attacker could include parameters in the HTTP requests that are sent to the Camel application that get translated into headers.  The headers could be both provided as request parameters for an HTTP methods invocation or as part of the payload of the HTTP methods invocation. All the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow, camel-platform-http, and camel-netty-http would be vulnerable out of the box. This CVE is related to the CVE-2025-27636: while they have the same root cause and are fixed with the same fix, CVE-2025-27636 was assumed to only be exploitable if an attacker could add malicious HTTP headers, while we have now determined that it is also exploitable via HTTP parameters. Like in CVE-2025-27636, exploitation is only possible if the Camel route uses particular vulnerable components.

SeverityMedium
CVSS4.8
Exploit probability—
ProductApache Camel
PublishedMar 12, 2025
First seenMar 12, 2025
Weakness typeCWE-164CWE-164

How to fix

Update
  • apache camel3.22.4, 4.8.5, 4.10.2 or later
  • org.apache.camel:camel-support3.22.4, 4.10.2, 4.8.5 or later

Affected products

ProductAffected versionsFixed in
apache camel3.10.0 ≤ v < 3.22.4, 4.8.0 ≤ v < 4.8.5, 4.10.0 ≤ v < 4.10.23.22.4, 4.8.5, 4.10.2
org.apache.camel:camel-supportMaven3.10.0 ≤ v < 3.22.4, 4.9.0 ≤ v < 4.10.2, 4.0.0-M1 ≤ v < 4.8.53.22.4, 4.10.2, 4.8.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.