CVE-2025-29953

Critical

Description

Deserialization of Untrusted Data vulnerability in Apache ActiveMQ NMS OpenWire Client. This issue affects Apache ActiveMQ NMS OpenWire Client before 2.1.1 when performing connections to untrusted servers. Such servers could abuse the unbounded deserialization in the client to provide malicious responses that may eventually cause arbitrary code execution on the client. Version 2.1.0 introduced a allow/denylist feature to restrict deserialization, but this feature could be bypassed. The .NET team has deprecated the built-in .NET binary serialization feature starting with .NET 9 and suggests migrating away from binary serialization. The project is considering to follow suit and drop this part of the NMS API altogether. Users are recommended to upgrade to version 2.1.1, which fixes the issue. We also recommend to migrate away from relying on .NET binary serialization as a hardening method for the future.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Activemq Nms Openwire
PublishedApr 18, 2025
First seenApr 18, 2025

How to fix

Update
  • apache activemq_nms_openwire2.1.1 or later
  • Apache.NMS.ActiveMQ2.1.1 or later

Affected products

ProductAffected versionsFixed in
apache activemq_nms_openwirev < 2.1.12.1.1
Apache.NMS.ActiveMQNuGetv < 2.1.12.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-29953 · Apache Activemq Nms Openwire · Dark Radar