CVE-2025-30067

High

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.

SeverityHigh
CVSS7.2
Exploit probability—
ProductApache Kylin
PublishedMar 27, 2025
First seenMar 27, 2025

How to fix

Update
  • apache kylin5.0.2 or later
  • org.apache.kylin:kylin5.0.2 or later

Affected products

ProductAffected versionsFixed in
apache kylin4.0.0 ≤ v < 5.0.25.0.2
org.apache.kylin:kylinMaven4.0.0 ≤ v < 5.0.25.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.