CVE-2025-30151
Description
Shopware is an open commerce platform. It's possible to pass long passwords that leads to Denial Of Service via forms in Storefront forms or Store-API. This vulnerability is fixed in 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
How to fix
- shopware shopware6.5.8.17, 6.6.10.3 or later
- shopware/core6.6.10.3, 6.7.0.0-rc2, 6.5.8.17 or later
- shopware/platform6.6.10.3, 6.7.0.0-rc2, 6.5.8.17 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| shopware shopware | v < 6.5.8.17, 6.6.0.0 ≤ v < 6.6.10.3, 6.7.0.0 | 6.5.8.17, 6.6.10.3 |
| shopware/corePackagist | 6.6.0.0 ≤ v < 6.6.10.3, 6.7.0.0-rc1 ≤ v < 6.7.0.0-rc2, v < 6.5.8.17 | 6.6.10.3, 6.7.0.0-rc2, 6.5.8.17 |
| shopware/platformPackagist | 6.6.0.0 ≤ v < 6.6.10.3, 6.7.0.0-rc1 ≤ v < 6.7.0.0-rc2, v < 6.5.8.17 | 6.6.10.3, 6.7.0.0-rc2, 6.5.8.17 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.