CVE-2025-30167

High

Description

Jupyter Core is a package for the core common functionality of Jupyter projects. When using Jupyter Core prior to version 5.8.0 on Windows, the shared `%PROGRAMDATA%` directory is searched for configuration files (`SYSTEM_CONFIG_PATH` and `SYSTEM_JUPYTER_PATH`), which may allow users to create configuration files affecting other users. Only shared Windows systems with multiple users and unprotected `%PROGRAMDATA%` are affected. Users should upgrade to Jupyter Core version 5.8.0 or later to receive a patch. Some other mitigations are available. As administrator, modify the permissions on the `%PROGRAMDATA%` directory so it is not writable by unauthorized users; or as administrator, create the `%PROGRAMDATA%\jupyter` directory with appropriately restrictive permissions; or as user or administrator, set the `%PROGRAMDATA%` environment variable to a directory with appropriately restrictive permissions (e.g. controlled by administrators _or_ the current user).

SeverityHigh
CVSS7.3
Exploit probability—
ProductJupyter Core
PublishedJun 3, 2025
First seenJun 3, 2025
Weakness typeCWE-427CWE-427

How to fix

Update
  • jupyter jupyter_core5.8.0 or later
  • jupyter-core5.8.1 or later

Affected products

ProductAffected versionsFixed in
jupyter jupyter_corev < 5.8.05.8.0
jupyter-corePyPIv < 5.8.15.8.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-30167 · Jupyter Core · Dark Radar