CVE-2025-30177
Description
Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions. This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6. Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS. Camel undertow component is vulnerable to Camel message header injection, in particular the custom header filter strategy used by the component only filter the "out" direction, while it doesn't filter the "in" direction. This allows an attacker to include Camel specific headers that for some Camel components can alter the behaviour such as the camel-bean component, or the camel-exec component.
How to fix
- apache camel4.8.6, 4.10.3 or later
- org.apache.camel:camel-undertow4.10.3, 4.8.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache camel | 4.8.0 ≤ v < 4.8.6, 4.10.0 ≤ v < 4.10.3 | 4.8.6, 4.10.3 |
| org.apache.camel:camel-undertowMaven | 4.10.0 ≤ v < 4.10.3, 4.8.0 ≤ v < 4.8.6 | 4.10.3, 4.8.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.