CVE-2025-30207

High

Description

Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development. Sites that use other server software (such as Apache, nginx or Caddy) are not affected. A missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP process, including files outside of the Kirby installation. The vulnerable implementation delegated all existing files to PHP, including existing files outside of the document root. This leads to a different response that allows attackers to determine whether the requested file exists. Because Kirby's router only delegates such requests to PHP and does not load or execute them, contents of the files were not exposed as PHP treats requests to files outside of the document root as invalid. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have updated the router to check if existing static files are within the document root. Requests to files outside the document root are treated as page requests of the error page and will no longer allow to determine whether the file exists or not.

SeverityHigh
CVSS7.5
Exploit probability—
ProductKirby
PublishedMay 13, 2025
First seenMay 13, 2025

How to fix

Update
  • getkirby kirby3.9.8.3, 3.10.1.2, 4.7.1 or later
  • getkirby/cms3.9.8.3, 3.10.1.2, 4.7.1 or later

Affected products

ProductAffected versionsFixed in
getkirby kirbyv < 3.9.8.3, 3.10.0 ≤ v < 3.10.1.2, 4.0.0 ≤ v < 4.7.13.9.8.3, 3.10.1.2, 4.7.1
getkirby/cmsPackagistv < 3.9.8.3, 3.10.0 ≤ v < 3.10.1.2, 4.0.0 ≤ v < 4.7.13.9.8.3, 3.10.1.2, 4.7.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.