CVE-2025-30218
Description
Next.js is a React framework for building full-stack web applications. To mitigate CVE-2025-29927, Next.js validated the x-middleware-subrequest-id which persisted across multiple incoming requests. However, this subrequest ID is sent to all requests, even if the destination is not the same host as the Next.js application. Initiating a fetch request to a third-party within Middleware will send the x-middleware-subrequest-id to that third party. This vulnerability is fixed in 12.3.6, 13.5.10, 14.2.26, and 15.2.4.
How to fix
- next12.3.6, 13.5.10, 14.2.26, 15.2.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | 12.3.5, 13.5.9, 14.2.25, 15.2.3 | — |
| nextnpm | 12.3.5 ≤ v < 12.3.6, 13.5.9 ≤ v < 13.5.10, 14.2.25 ≤ v < 14.2.26, 15.2.3 ≤ v < 15.2.4 | 12.3.6, 13.5.10, 14.2.26, 15.2.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.