CVE-2025-30677
Description
Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs. This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue. This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4. 3.0.x version users should upgrade to at least 3.0.11. 3.3.x version users should upgrade to at least 3.3.6. 4.0.x version users should upgrade to at least 4.0.4. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
How to fix
- apache pulsar3.0.11, 3.3.6, 4.0.4 or later
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor3.0.11, 3.3.6, 4.0.4 or later
- org.apache.pulsar:pulsar-io-kafka3.0.11, 3.3.6, 4.0.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache pulsar | 2.3.0 ≤ v < 3.0.11, 3.3.0 ≤ v < 3.3.6, 4.0.0 ≤ v < 4.0.4 | 3.0.11, 3.3.6, 4.0.4 |
| org.apache.pulsar:pulsar-io-kafka-connect-adaptorMaven | v < 3.0.11, 3.3.0 ≤ v < 3.3.6, 4.0.0 ≤ v < 4.0.4 | 3.0.11, 3.3.6, 4.0.4 |
| org.apache.pulsar:pulsar-io-kafkaMaven | v < 3.0.11, 3.3.0 ≤ v < 3.3.6, 4.0.0 ≤ v < 4.0.4 | 3.0.11, 3.3.6, 4.0.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.