CVE-2025-31125
Description
Vite is a frontend tooling framework for javascript. Vite exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. This vulnerability is fixed in 6.2.4, 6.1.3, 6.0.13, 5.4.16, and 4.5.11.
How to fix
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
CISA due date: Feb 12, 2026- vitejs vite4.5.11, 5.4.16, 6.0.13, 6.1.3, 6.2.4 or later
- vite6.2.4, 6.1.3, 6.0.13, 5.4.16, 4.5.11 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vitejs vite | v < 4.5.11, 5.0.0 ≤ v < 5.4.16, 6.0.0 ≤ v < 6.0.13, 6.1.0 ≤ v < 6.1.3, 6.2.0 ≤ v < 6.2.4 | 4.5.11, 5.4.16, 6.0.13, 6.1.3, 6.2.4 |
| vitenpm | 6.2.0 ≤ v < 6.2.4, 6.1.0 ≤ v < 6.1.3, 6.0.0 ≤ v < 6.0.13, 5.0.0 ≤ v < 5.4.16, v < 4.5.11 | 6.2.4, 6.1.3, 6.0.13, 5.4.16, 4.5.11 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.