CVE-2025-31493

Critical

Description

Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby sites that use the `collection()` helper or `$kirby->collection()` method with a dynamic collection name (such as a collection name that depends on request or user data). Sites that only use fixed calls to the `collection()` helper/`$kirby->collection()` method (i.e. calls with a simple string for the collection name) are *not* affected. A missing path traversal check allowed attackers to navigate and access all files on the server that were accessible to the PHP process, including files outside of the collections root or even outside of the Kirby installation. PHP code within such files was executed. Such attacks first require an attack vector in the site code that is caused by dynamic collection names, such as `collection('tags-' . get('tags'))`. It generally also requires knowledge of the site structure and the server's file system by the attacker, although it can be possible to find vulnerable setups through automated methods such as fuzzing. In a vulnerable setup, this could cause damage to the confidentiality and integrity of the server. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have added a check for the collection path that ensures that the resulting path is contained within the configured collections root. Collection paths that point outside of the collections root will not be loaded.

SeverityCritical
CVSS9.1
Exploit probability—
ProductKirby
PublishedMay 13, 2025
First seenMay 13, 2025

How to fix

Update
  • getkirby kirby3.9.8.3, 3.10.1.2, 4.7.1 or later
  • getkirby/cms3.9.8.3, 3.10.1.2, 4.7.1 or later

Affected products

ProductAffected versionsFixed in
getkirby kirbyv < 3.9.8.3, 3.10.0 ≤ v < 3.10.1.2, 4.0.0 ≤ v < 4.7.13.9.8.3, 3.10.1.2, 4.7.1
getkirby/cmsPackagistv < 3.9.8.3, 3.10.0 ≤ v < 3.10.1.2, 4.0.0 ≤ v < 4.7.13.9.8.3, 3.10.1.2, 4.7.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.