CVE-2025-31672

Medium

Description

Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry. This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file. Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read https://poi.apache.org/security.html for recommendations about how to use the POI libraries securely.

SeverityMedium
CVSS5.3
Exploit probability—
ProductApache Poi
PublishedApr 9, 2025
First seenApr 9, 2025

How to fix

Update
  • apache poi5.4.0 or later
  • org.apache.poi:poi-ooxml5.4.0 or later

Affected products

ProductAffected versionsFixed in
apache poiv < 5.4.05.4.0
netapp active_iq_unified_managerNo range specified—
org.apache.poi:poi-ooxmlMavenv < 5.4.05.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-31672 · Apache Poi · Dark Radar