CVE-2025-3202

High

Description

A vulnerability classified as critical has been found in ageerle ruoyi-ai up to 2.0.0. Affected is an unknown function of the file ruoyi-modules/ruoyi-system/src/main/java/org/ruoyi/system/controller/system/SysNoticeController.java. The manipulation leads to improper authorization. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.1 is able to address this issue. The name of the patch is 6382e177bf90cc56ff70521842409e35c50df32d. It is recommended to upgrade the affected component.

SeverityHigh
CVSS7.3
Exploit probability—
ProductAgeerle Ruoyi-ai
PublishedApr 4, 2025
First seenApr 4, 2025

How to fix

Affected products

ProductAffected versionsFixed in
ageerle ruoyi-aiv < 2.0.12.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-3202 · Ageerle Ruoyi-ai · Dark Radar