CVE-2025-32027

Medium

Description

Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.

SeverityMedium
CVSS6.1
Exploit probability—
ProductYiisoft/yii
PublishedApr 10, 2025
First seenApr 10, 2025

How to fix

Update
  • yiisoft/yii1.1.31 or later
  • yiiframework yii1.1.31 or later

Affected products

ProductAffected versionsFixed in
yiisoft/yiiPackagistv < 1.1.311.1.31
yiiframework yiiv < 1.1.311.1.31

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-32027 · Yiisoft/yii · Dark Radar