CVE-2025-32430
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions 4.2-milestone-3 through 16.4.7, 16.5.0-rc-1 through 16.10.5 and 17.0.0-rc-1 through 17.2.2, two templates contain reflected XSS vulnerabilities, allowing an attacker to execute malicious JavaScript code in the context of the victim's session by getting the victim to visit an attacker-controlled URL. This permits the attacker to perform arbitrary actions using the permissions of the victim. This issue is fixed in versions 16.4.8, 16.10.6 and 17.3.0-rc-1. To workaround the issue, manually patch the WAR with the same changes as the original patch.
How to fix
- xwiki xwiki16.4.8, 16.10.6 or later
- org.xwiki.platform:xwiki-platform-web-templates16.4.8, 16.10.6, 17.3.0-rc-1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| xwiki xwiki | 4.3 ≤ v < 16.4.8, 16.5.0 ≤ v < 16.10.6, 17.0.0 ≤ v ≤ 17.2.2, 4.2, 16.5.0 | 16.4.8, 16.10.6 |
| org.xwiki.platform:xwiki-platform-web-templatesMaven | 4.2-milestone-3 ≤ v < 16.4.8, 16.5.0-rc-1 ≤ v < 16.10.6, 17.0.0-rc-1 ≤ v < 17.3.0-rc-1 | 16.4.8, 16.10.6, 17.3.0-rc-1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.