CVE-2025-32432
Description
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.
How to fix
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
CISA due date: Apr 3, 2026- craftcms craft_cms3.9.15, 4.14.15, 5.6.17 or later
- craftcms/cms3.9.15, 4.14.15, 5.6.17 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_cms | 3.0.0 ≤ v < 3.9.15, 4.0.0 ≤ v < 4.14.15, 5.0.0 ≤ v < 5.6.17 | 3.9.15, 4.14.15, 5.6.17 |
| craftcms/cmsPackagist | 3.0.0-RC1 ≤ v < 3.9.15, 4.0.0-RC1 ≤ v < 4.14.15, 5.0.0-RC1 ≤ v < 5.6.17 | 3.9.15, 4.14.15, 5.6.17 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.