CVE-2025-32442
Description
Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.
How to fix
- fastify fastify5.3.2 or later
- fastify5.8.5, 5.3.2, 4.29.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| fastify fastify | 5.0.0 ≤ v < 5.3.2, 4.29.0 | 5.3.2 |
| fastifynpm | 5.3.2 ≤ v < 5.8.5, 5.0.0 ≤ v < 5.3.2, 4.29.0 ≤ v < 4.29.1 | 5.8.5, 5.3.2, 4.29.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.