CVE-2025-32444

Critical

Description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.

SeverityCritical
CVSS10.0
Exploit probability—
ProductVllm
PublishedApr 30, 2025
First seenApr 30, 2025

How to fix

Update
  • vllm vllm0.8.5 or later
  • vllm0.8.5 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.6.5 ≤ v < 0.8.50.8.5
vllmPyPI0.6.5 ≤ v < 0.8.50.8.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-32444 · Vllm · Dark Radar