CVE-2025-32968
Description
XWiki is a generic wiki platform. In versions starting from 1.6-milestone-1 to before 15.10.16, 16.4.6, and 16.10.1, it is possible for a user with SCRIPT right to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. This issue has been patched in versions 16.10.1, 16.4.6 and 15.10.16. There is no known workaround, other than upgrading XWiki. The protection added to this REST API is the same as the one used to validate complete select queries, making it more consistent. However, while the script API always had this protection for complete queries, it's important to note that it's a very strict protection and some valid, but complex, queries might suddenly require the author to have programming right.
How to fix
- xwiki xwiki15.10.16, 16.4.6 or later
- org.xwiki.platform:xwiki-platform-oldcore15.10.16, 16.4.6, 16.10.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| xwiki xwiki | 1.6 ≤ v < 15.10.16, 16.0.0 ≤ v < 16.4.6, 16.5.0 ≤ v ≤ 16.10.1 | 15.10.16, 16.4.6 |
| org.xwiki.platform:xwiki-platform-oldcoreMaven | 1.6-milestone-1 ≤ v < 15.10.16, 16.0.0-rc-1 ≤ v < 16.4.6, 16.5.0-rc-1 ≤ v < 16.10.1 | 15.10.16, 16.4.6, 16.10.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.