CVE-2025-32972
Description
XWiki is a generic wiki platform. In versions starting from 6.1-milestone-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.
How to fix
- xwiki xwiki15.10.12, 16.4.3, 16.8.0 or later
- org.xwiki.platform:xwiki-platform-lesscss-script15.10.12, 16.4.3, 16.8.0-rc-1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| xwiki xwiki | 6.2 ≤ v < 15.10.12, 16.0.0 ≤ v < 16.4.3, 16.5.0 ≤ v < 16.8.0, 6.1 | 15.10.12, 16.4.3, 16.8.0 |
| org.xwiki.platform:xwiki-platform-lesscss-scriptMaven | 6.1-milestone-1 ≤ v < 15.10.12, 16.0.0-rc-1 ≤ v < 16.4.3, 16.5.0-rc-1 ≤ v < 16.8.0-rc-1 | 15.10.12, 16.4.3, 16.8.0-rc-1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.