CVE-2025-33042
High
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Avro Java SDK when generating specific records from untrusted Avro schemas. This issue affects Apache Avro Java SDK: all versions through 1.11.4 and version 1.12.0. Users are recommended to upgrade to version 1.12.1 or 1.11.5, which fix the issue.
SeverityHigh
CVSS7.3
Exploit probability—
Product
Apache Avro
PublishedFeb 13, 2026
First seenFeb 13, 2026
Weakness typeCWE-94Code injection
How to fix
Update
- apache avro1.11.5 or later
- avro1.11.5 or later
- org.apache.avro:avro-compiler1.12.1, 1.11.5 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache avro | v < 1.11.5, 1.12.0 | 1.11.5 |
| avroPyPI | v < 1.11.5 | 1.11.5 |
| org.apache.avro:avro-compilerMaven | 1.12.0 ≤ v < 1.12.1, v < 1.11.5 | 1.12.1, 1.11.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.